Drieam - Assignments sporadically not marked as completed or graded in Canvas after Qualtrics survey submission – Incident details

Assignments sporadically not marked as completed or graded in Canvas after Qualtrics survey submission

Resolved
Degraded performance
Started 13 days agoLasted 12 days

Affected

Qualtrics LTI

Degraded performance from 3:30 PM to 7:57 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved. We have confirmed that Qualtrics responses from 11th September 08:27 UTC for surveys with the Canvas submission setting enabled will have been posted successfully to Canvas. As we noted in our recent email, even though the issue is resolved, you still need to make sure your datacenter IDs are updated. Please let us know once you have done so. Our sincere apologies for any inconvenience caused.
  • Update
    Update

    We have identified a technical issue. Since at least Friday, September 5th, some submissions for Canvas assignments are not being marked as complete or graded after a student has responded to the survey. We sincerely apologize for any inconvenience this has caused.

    Not all customers were impacted. This issue might have impacted you if one or more of your surveys met the following criteria:

    • The survey was live in recent weeks.

    • The survey was set to one of the ‘With Canvas submission’ grading options. If you have ‘No Canvas submission’ set on all of your surveys, you should not have been impacted by this issue.

      Screenshot 2025-09-12 at 16.47.52.png

    The problem has been addressed. For most customers, any impacted survey submissions should now be corrected and present in Canvas. However, there are two important points to note:

    • The timestamp might not be when the student actually submitted the survey. If you have due dates set on your Canvas assignments, we recommend checking the response date & time in Qualtrics for each student submission that might have been marked as late.

    • If your Qualtrics organization URL contains a legacy Qualtrics datacenter ID, or if it is a Qualtrics vanity URL, this issue is not yet resolved. We will reach out to you next week (on Monday, September 15th) if you are still affected by this issue with next steps. This is the list of legacy Qualtrics datacenter IDs:

      • ca1

      • co1

      • az/az1

      • sjc1

      • eu/eu1/eu2

      • au1

    We appreciate your patience as we work to resolve this issue as quickly as possible. If you have questions, please don’t hesitate to reach out. We'd be happy to set up a meeting to help you.



  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.