Qualtrics LTI Maintenance 18th of May (10:00 - 12:00 CEST)
Scheduled for May 18th, 2024 at 8.00 – 10.00
Affects
Qualtrics LTI
Under maintenance from 8:00 AM to 10:00 AM
Completed
May 18th, 2024 at 10.00Completed
May 18th, 2024 at 10.00Maintenance has completed successfully
In progress
May 18th, 2024 at 8.00In progress
May 18th, 2024 at 8.00Maintenance is now in progress
Planned
May 18th, 2024 at 8.00Planned
May 18th, 2024 at 8.00Dear customers,
We would like to inform you about a scheduled maintenance activity that will take place on Saturday the 18th of May between 10:00 - 12:00 CEST.
We appreciate your understanding and cooperation as we work to make our services even better.
Kind regards,
The Qualtrics LTI team