Drieam - Slow performance overall – Incident details

Slow performance overall

Resolved
Degraded performance
Started almost 2 years agoLasted 6 days

Affected

Portflow

Degraded performance from 12:58 PM to 8:10 AM

Updates
  • Resolved
    Resolved

    We have resolved the performance issue and will be closely monitoring the performance. Also, we will be making sure to take preventative measures for the future.

  • Monitoring
    Monitoring

    We have implemented a fix and currently monitoring the result. The initial findings yield response times to appear to be quite a bit shorter. This means that the performance has been improved. We are currently working on more optimizations for the performance.

    Next update before: 17.00

  • Identified
    Update

    We are currently rolling out a new release and will be monitoring the result after the release.

    Next update before: 15.00h

  • Identified
    Identified

    We have identified the probable cause of the issue and are working on a fix. We hope to be able to finish and push this as soon as possible.

    Next update before: 14.00 h

  • Investigating
    Update

    We are still investigating the root cause of the performance issues. After a big upgrade of our servers and effectively reverting the releases that were done last week, we still experience the same slow performance. Therefore, we can say that the most probable cause lies within growing pains as we simultaneously saw a 50% increase of usage over the last couple of weeks. We're currently in the progress of further analyses and optimizations and will be looking to prevent this from happening again in the future.

    Next update before: December 6th, 17.00h.

  • Investigating
    Update

    We are still working hard to investigate the source of the performance issues. We're truly sorry about the caused inconvenience.

    Next update before: 17.00.

  • Investigating
    Investigating

    We are experiencing increased response times again this morning. As we continue our investigation, we will temporarily disable the file preview generation.

  • Monitoring
    Monitoring

    We have upgraded the database and are monitoring the result. Meanwhile, we keep looking for the root cause of the issue.

  • Investigating
    Update

    We are still investigating this incident. At 17.00 pm we will do an upgrade to our servers to temporary solve the issue, while we continue to look for the root cause. This might cause a short downtime.

  • Investigating
    Investigating

    We are currently experiencing a slow performance on Portflow. We are now investigating the cause of the issue.